OVP Forums - A community of assistance, help, questions, and answers.
  FAQFAQ    SearchSearch      RegisterRegister  ProfileProfile    Log in to check your private messagesLog in to check your private messages    Log inLog in
Linux_ArmIntegratorCP could not initialize SDL

 
Post new topic   Reply to topic    Open Virtual Platforms Forum Index -> First time - readme
View previous topic :: View next topic  
Author Message
Mathi90



Joined: 04 May 2017
Posts: 2
Location: Hanover

PostPosted: Wed Jul 12, 2017 5:09 am    Post subject: Linux_ArmIntegratorCP could not initialize SDL Reply with quote

Hello,

when i try to run the Demo of the ARMIntegratorCP by executing .../harness/RUN_ARMIntegratorCP.sh i get the following error-messages at the end of the output:
Code:
Info (PSE_SER) 'ArmIntegratorCP/uart1' Connected to 46693
Error (SDL_FIS) Could not initialize SDL
Error (PL110_UIS) Unable to initialize SDL display
Error (OP_FIP) Failed to initialize platform


A little black window flashes shortly but then disappears.

My OVP Version is 20170201, the ARM Integrator Version is 20170511, i have libsdl1.2 installed.

It would be great if i could get some help, thanks in advance,

Mathias
Back to top
View user's profile Send private message
DuncGrah
OVP Technologist
OVP Technologist


Joined: 27 Feb 2008
Posts: 1639
Location: United Kingdom

PostPosted: Tue Jul 18, 2017 2:02 am    Post subject: Reply with quote

Have you installed anything separately regarding SDL than the libraries provided by OVP in the installations?
This error can happen when you are using a remote machine i.e. a display cannot be opened but the fact that you say a black box appears and then disappears and then the error message generated makes me think that the SDL is trying to draw a screen but then an incompatibility in the SDL API is causing an error
Back to top
View user's profile Send private message Visit poster's website
Mathi90



Joined: 04 May 2017
Posts: 2
Location: Hanover

PostPosted: Tue Jul 18, 2017 2:27 am    Post subject: Reply with quote

Hello,

i did not install anything separately, just the mentioned installations. I am, however, working on a thin client.
Currently i am avoiding the problem by disabling the lcd and just using the terminal, which is sufficient for my intentions. So should this be a problem with my host, i will not make further efforts.

Thank you for your help,
Mathias
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Open Virtual Platforms Forum Index -> First time - readme All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Information regarding OVP © 2008-2022 Imperas Software